sexta-feira, 28 de fevereiro de 2014

Plugin do Flash no Linux

O plugin do Flash (usado, por exemplo, para ver videos como os do site Youtube) costuma dar um certo trabalho em Linux. As vezes você baixa o plugin do site da Adobe e ele não funciona direito.

Para resolver isso de uma forma simples basta instalar no pacote flashplugin-nonfree.

# apt-get install flashplugin-nonfree

Segundo a documentação do pacote...

"Este pacote baixará o Flash Player da Adobe. É uma extensão do tipo
Netscape/Mozilla. Qualquer navegador baseado no Netscape ou Mozilla pode
usar o Flash Player. Atualmente, este pacote dá suporte aos seguintes
navegadores: Mozilla, Mozilla-Firefox, Firefox, Iceweasel e Iceape. O
Galeon e o Epiphany também podem usar o Flash Player. O Konqueror também
pode usar o Flash Player se o pacote konqueror-nsplugins estiver
instalado.

AVISO: Ao instalar este pacote Debian, o Adobe Flash Player será baixado
a partir de www.adobe.com. O Contrato de Licença de Usuário Final
(EULA -- End User License Agreement) do Adobe Flash Player está disponível
em www.adobe.com."

Se você usa o Debian precisará habilitar os pacotes non-free no seu arquivo /etc/apt/sources.list. Deverá ficar como no exemplo abaixo:

deb http://ftp.br.debian.org/debian/ stable contrib non-free main